[修正phpMyAdmin的所述配置文件现在需要一个秘密密钥(blowfish_secret)

是否已安装 phpMyAdmin的 服务器 Ubuntu的, CentOS的 或等。 Fedora的 分布,消息“配置文件现在需要一个秘密口令(blowfish_secret)“在指数的底部有红色,令人头疼。 特别是在“正确配置”中/etc/phpMyAdmin/config.inc.php“。
当然,路径可能因配置而异,但也可能不同 CentOS 7的 cu phpMyAdmin的 通过“安装百胜“在”remi.repo“配置文件将位于”在/ etc / phpMyAdmin的/”。

好的,让我们看看我们如何解决“配置文件现在需要一个秘密口令(blowfish_secret)“如果在 config.inc.php文件 我们这行:

$ CFG [ 'blowfish_secret'] = '$ $ gNsWq%#%#%EDFSsffsegbVp6LCJw6w'; / *您必须填写在本作COOKIE A​​UTH! * /

如果该行存在,我们必须在phpMyAdmin红色消息的“钥匙”在32字符应该消失。
如果这种情况没有发生,你应该从你的浏览器中删除Cookie和注销的phpMyAdmin。 在下次登录时,该消息“配置文件现在需要一个秘密口令(blowfish_secret)“我将不存在。
虽然在有些情况下,它存在 不是由于错误配置 config.inc.php文件,但是因为 文件夹的权限时,他是.

在终端命令行运行:

 chown -R root:<user web> / etc / phpMyAdmin /

现在一切都应该没问题。 如果您使用Apache而不是“user web”,请设置“httpd”,“nginx”或如何在服务器上拥有Web进程的用户。

我写了这些技巧,因为我通过整个phpMyAdmin配置在2小时内变得更好,我仍然没有消除这个消息:配置文件现在需要一个秘密密码(blowfish_secret)。 在我清除权限/组后,她消失了。

[修正phpMyAdmin的所述配置文件现在需要一个秘密密钥(blowfish_secret)

关于作者

隐形LP

创始人和主编 隐身设置在2006日期。
具有Linux操作系统(尤其是CentOS),Mac OS X, Windows XP> Windows 10和WordPress(CMS)。

3评论

发表回复 Baganaakh X