[修复phpMyAdmin]配置 file 现在需要一个秘密密码(blowfish_secret)

是否已安装 phpMyAdmin的 服务器 Ubuntu的, CentOS的 或等。 Fedora的 分发,消息“配置 file 现在需要一个秘密密码(blowfish_secret)索引底部的红色表示令人头疼。 特别是在“/etc/phpMyAdmin/config.inc.php“。
当然,从一种配置到另一种配置,路径可能有所不同,但在 CentOS 7的 cu phpMyAdmin的 通过“百胜“从”remi.repo“,配置文件将位于“ / etc / phpMyAdmin /”中。

好吧,让我们看看我们如何解决“配置 file 现在需要一个秘密密码(blowfish_secret)“,如果在 config.inc.php文件 我们这行:

$cfg['blowfish_secret'] = 'gNsWq$%#%$#%EDFSsffsegbVp6LCJw6w'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */

如果此行存在并且我们的“键”超过32个字符,则phpMyAdmin中的红色消息应消失。
如果没有发生,最好在浏览器中删除cookie并注销phpMyAdmin。 下次登录时,消息“配置 file 现在需要一个秘密密码(blowfish_secret)“他将不再在场。
虽然在有些情况下,它存在 不是由于错误配置 config.inc.php文件,但是因为 文件夹的权限时,他是.

在终端命令行运行:

 chown -R root:<user web> /etc/phpMyAdmin/

现在一切都可以了。 如果使用Apache,而不是“ Web用户”,则设置“ httpd”,“ nginx”或在服务器上如何设置Web进程用户。

我写这些技巧是因为我经过了所有phpMyAdmin配置超过2个小时,但仍然无法摆脱此消息: file 现在需要一个秘密密码(blowfish_secret)。 解决权限/组后,它消失了。

[修复phpMyAdmin]配置 file 现在需要一个秘密密码(blowfish_secret)

关于作者

隐形LP

创始人和主编 隐形 Settings在2006日期。
具有Linux操作系统(尤其是CentOS)方面的经验, Mac OS X, Windows XP> Windows 10 和WordPress(CMS)。

4条评论

发表评论